No further issues have been seen since the fix was implemented.
An incident report will follow soon.
Posted Aug 25, 2026 - 12:06 BST
Monitoring
A fix has been implemented for all sites, and we'll continue to monitor all sites.
Posted Aug 25, 2026 - 10:02 BST
Update
Some affected sites are not using AWS CloudFront. We now believe this issue may affect all Heroku sites, including those using Cloudflare which were deployed a long time ago.
Posted Aug 25, 2026 - 09:33 BST
Investigating
We are currently investigating reports of outages for sites hosted behind AWS CloudFront as their CDN.
Sites using Cloudflare as their CDN, or otherwise not using CloudFront are unaffected.